Одинаковые номера п/п для повторяющихся записей
Номера п/п для повторяющихся записей





Как формулой сделать одинаковые номера для повторяющихся записей? Они отсортированы, но число повторений каждой записи – разное.

MS Office для Windows

Все мои курсы

Шаблоны


Скачать файл
Смотреть курс
Теги: Вопрос-ответ по Excel.

Номера п/п для повторяющихся записей

Как формулой сделать одинаковые номера для повторяющихся записей? Они отсортированы, но число повторений каждой записи – разное. Excel-III: PRO функции

Как формулой записать одинаковые порядковые номера для одинаковых записей? Таково было желание участника одного из моих курсов.

Формула для ячейки A4: 

=ЕСЛИ(СЧЁТЕСЛИ($B$3:B4; B4)>1; A3; МАКС($A$3:A3)+1)

Как прочитать эту формулу:

Обучение по функциям можно пройти отдельно, смотрите расписание здесь.

ВИДЕО с примером в Instagram и Facebook можно посмотреть у olesya.excel по хэштегу #лис_ном_90

 

Полезные материалы

Как сделать таблицу в Excel для учёта домашних финансов
Домашний бюджет в EXCEL
Считаем деньги в Excel

Удобный календарь по неделям, с фильтрацией
Календарь со срезами
Автоматизированный календарь - выходные и праздники выделяются сами, возможна фильтрация прошедших и будущих дат, записей с определённым текстом.

Между числами много пробелов - меняем их на знак переноса
Выгрузка из системы - обработка пробелов
Как в Excel убрать лишние пробелы между словами в ячейке, между числами? Как заменить пробел на другой текст? Как вставить знак переноса текста внутри ячейки формулой? Как включить перенос текста?

Выпадающий список с автоподбором по нескольким буквам
Динамическое обновление выпадающего списка значений
Как сделать выпадающий список зависимым от введённых букв?

Мои ученики работают здесь

Я сотрудничаю с крупными известными компаниями. Вот некоторые из них:

ВТБ МегаФон Глобус Абсолют

Связаться с автором

Оставьте ваше имя и адрес электронной почты, в ближайшее время я свяжусь
с вами для консультации и отвечу на вопросы!



Оставляя заявку, вы соглашаетесь на обработку ваших персональных данных.