Одинаковые номера п/п для повторяющихся записей

Номера п/п для повторяющихся записей

Как формулой сделать одинаковые номера для повторяющихся записей? Они отсортированы, но число повторений каждой записи – разное. Excel-III: PRO функции

Как формулой записать одинаковые порядковые номера для одинаковых записей? Таково было желание участника одного из моих курсов.

Формула для ячейки A4: 

=ЕСЛИ(СЧЁТЕСЛИ($B$3:B4; B4)>1; A3; МАКС($A$3:A3)+1)

Как прочитать эту формулу:

Функцию ЕСЛИ я подробно показываю на курсе "PRO ФУНКЦИИ", СЧЁТЕСЛИ вошла в курс "ПРОСТЫЕ ФОРМУЛЫ". Оба курса можно купить пакетом по выгодной цене.

ВИДЕО с примером в Инстаграмме и Фэйсбуке: НАЖМИТЕ ЗДЕСЬ