Ссылка на последнюю ячейку
Получение данных по последней заполняемой ячейке





Разбираем различные задачи из реальной практики в Microsoft Excel и находим успешные решения. К примеру вложен файл с образцом, его можно скачать по кнопке.

MS Office для Windows

Все мои курсы

Шаблоны


Скачать файл
Смотреть курс
Теги: Вопрос-ответ по Excel.

Получение данных по последней заполняемой ячейке

Разбираем различные задачи из реальной практики в Microsoft Excel и находим успешные решения. К примеру вложен файл с образцом, его можно скачать по кнопке. Excel-V: Формулы массива

Сейчас разберем вопрос, как автоматизировать подстановку данных в нужную ячейку из последнего заполненного столбца. На самом деле, если есть таблица, постоянно пополняющаяся данными и в другой ячейке нужно выделить самые последние из них, то почему бы не заставить Excel решать эту задачу вместо нас? Моя таблица будет пополняться данными по дням в течение года и для удобства над таблицей необходимо видеть общий итог по ней, а также последние внесенные данные (то есть за последний операционный день). Расчет общего значения прост – там автосумма по итоговой строке, а вот что делать с последним днем – не править же каждый раз значение вручную, как это показано на рисунке:

В решении такого вопроса могут помочь две функции – ВПР либо ИНДЕКС . Разберем обе

Решение с помощью ВПР

Вот такая получилась формула =ВПР("ИТОГО*";A:G;СЧЁТЕСЛИ(B14:G14;">0")+1;0) , а работает следующим образом:

Решение с помощью ИНДЕКС

Этот вариант решения мне представляется более простым, хотя и функцию используем возможно менее знакомую. Идея та же – в диапазоне итоговых данных нужно посчитать порядковый номер последнего положительного значения и вытащить его в ячейку. Формула получается вот такая =ИНДЕКС(B14:G14;1;СЧЁТЕСЛИ(B14:G14;">0")) , а принципы ее работы ниже:

Полезные материалы

Переделка номеров текстовыми функциями
Исправление текста в ячейке с помощью текстовых функций
Как убрать лишние символы из ячеек формулой? Как разделить текст формулами? Как собрать текст в одну ячейку?

Формулы массива для расчёта минимального ненулевого значения
Проверка диапазона МИН функцией ЕСЛИ
Как научить функцию МИН выбирать минимальное значение и не учитывать при этом нули?

1 апрельские приколы для офиса
Файл Excel  с чёрными листами
Самый странный файл для Ваших коллег

Macro-функция поиска заголовка по данным из таблицы
Function VBA Поиск заголовка
Разбираем различные задачи из реальной практики в Microsoft Excel и находим успешные решения. К примеру вложен файл с образцом, его можно скачать по кнопке.

Мои ученики работают здесь

Я сотрудничаю с крупными известными компаниями. Вот некоторые из них:

ВТБ МегаФон Глобус Абсолют

Связаться с автором

Оставьте ваше имя и адрес электронной почты, в ближайшее время я свяжусь
с вами для консультации и отвечу на вопросы!



Оставляя заявку, вы соглашаетесь на обработку ваших персональных данных.