Ссылка на последнюю ячейку

Получение данных по последней заполняемой ячейке

Разбираем различные задачи из реальной практики в Microsoft Excel и находим успешные решения. К примеру вложен файл с образцом, его можно скачать по кнопке. Excel-V: Формулы массива

Сейчас разберем вопрос, как автоматизировать подстановку данных в нужную ячейку из последнего заполненного столбца. На самом деле, если есть таблица, постоянно пополняющаяся данными и в другой ячейке нужно выделить самые последние из них, то почему бы не заставить Excel решать эту задачу вместо нас? Моя таблица будет пополняться данными по дням в течение года и для удобства над таблицей необходимо видеть общий итог по ней, а также последние внесенные данные (то есть за последний операционный день). Расчет общего значения прост – там автосумма по итоговой строке, а вот что делать с последним днем – не править же каждый раз значение вручную, как это показано на рисунке:

В решении такого вопроса могут помочь две функции – ВПР либо ИНДЕКС . Разберем обе

Решение с помощью ВПР

Вот такая получилась формула =ВПР("ИТОГО*";A:G;СЧЁТЕСЛИ(B14:G14;">0")+1;0) , а работает следующим образом:

Решение с помощью ИНДЕКС

Этот вариант решения мне представляется более простым, хотя и функцию используем возможно менее знакомую. Идея та же – в диапазоне итоговых данных нужно посчитать порядковый номер последнего положительного значения и вытащить его в ячейку. Формула получается вот такая =ИНДЕКС(B14:G14;1;СЧЁТЕСЛИ(B14:G14;">0")) , а принципы ее работы ниже: